15 code but engine's not over heating - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-11-2003, 07:48 PM
RedRock
Guest
 
Posts: n/a
15 code but engine\'s not over heating

I keep getting the coolant sensor circuit high tempurature light. I changed the tempurature sensor but it still comes back. I recleaned all the ground wires and the connector to the computer.

One thing that seem new is I hear a clicking like morris code from the computer after I drive about a quarter of a mile.

I keep disconnecting the battery to reset and this comes back every month or two out of the blue.

Anyone had this problem and figured out a fix.

Thanks - Larry
[img]images/graemlins/thud.gif[/img]

I forgot to add this is a '94 Sammie with EFI.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-13-2003, 06:31 PM
RedRock
Guest
 
Posts: n/a
Re: 15 code but engine\'s not over heating

Nobody's knows this one??? Come on, somebody on this group knows everything!!!
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome