Is there anybody out who had eletrical probelm? - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-03-2003, 06:57 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Is there anybody out who had eletrical probelm?

My highbeam light on dash stay on. If I pull fuses out of head light it go out. If I pull overhead light out the light in dash goes out.The horn quit working, it only buzzes when you push it.Also the door buzzer is giving me probelms.If anybody knows what to do or had this probelm please let me know.I also have a whole suzuki for sale parts only no title. [img]images/graemlins/crybaby.gif[/img]
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-03-2003, 07:59 PM
Keyboard Implanted
 
87zuke's Avatar
 
Join Date: Mar 2000
Location: Southern, Ct.
Posts: 2,747
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Is there anybody out who had eletrical probelm?

I'm assuming you have a Sammi and if so these things can be an electrical nightmare. Try connecting a heavy gauge wire from the body to the frame and clean off the grounds on the firewall. The grounds have a way of corroding. HTH. Jim
87zuke is offline  
post #3 of (permalink) Old 06-03-2003, 08:09 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Is there anybody out who had eletrical probelm?

Thank you I will try that in the morning. [img]images/graemlins/grin.gif[/img]
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 06-03-2003, 10:34 PM
 
Join Date: Feb 2003
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Is there anybody out who had eletrical probelm?

Believe it or not, same thing happened in my VW once.


With me, it was a bad fuse, seriously, try putting a new one in, it was not burnt, just bad.

Alex
adasilva76 is offline  
post #5 of (permalink) Old 06-03-2003, 10:54 PM
 
Join Date: Aug 2002
Posts: 403
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Is there anybody out who had eletrical probelm?

Mine does almost the exact same things ......mine started when I tried hooking up an el-cheapo radio from Walmart...so I suppose I shorted something out somewhere..I ended up putting my old radio back in just to have some tunes ...never got the Walmart radio to do right. [img]images/graemlins/chair.gif[/img]
southpawz is offline  
post #6 of (permalink) Old 06-04-2003, 12:29 AM
HankS
Guest
 
Posts: n/a
Re: Is there anybody out who had eletrical probelm?

To fix the horn, clean it with some carb cleaner and back out the screw in it until it will operate normally (probably just corroded) then you can tune it after it begins to loosen up.
As far as your wiring nightmare, sounds like a bad ground or a short. When my door buzzer shorted it showed some of the same signs, the wires were cut and rubbing against metal, it was pretty annoying. Good luck...
post #7 of (permalink) Old 06-04-2003, 12:50 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Is there anybody out who had eletrical probelm?

I am still looking for the probelm. I ran a ground wire from the (-) side of battery to the fire wall and to the dash ground. This still did not fix probelm.But I did hook up a new radio, but I hook it to the fuse block.Thank all of yall that are helping me, when I find the probelm I will let yall know. [img]images/graemlins/thud.gif[/img]
post #8 of (permalink) Old 06-04-2003, 01:19 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Is there anybody out who had eletrical probelm?

I just want to thank journeyman.I replace all the fuses in fuse block. Everything started working. [img]images/graemlins/40BEER.gif[/img]
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome