Progressive Hard Starting - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-01-2003, 05:03 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Progressive Hard Starting

Hey folks,

I've searched the board and not been able to find the answer.

Lately my spook has been an absolute pig to start. It've replaced the rotor button, rotor cap, leads, plugs and battery and it still takes a few mins of cranking to get it to start.

Once it does fire up it idles nice and smoothly. If the engine has been running it will fire up without to much hassel. Mind you the longer I leave it to cool down the harder it is to start.

I'm not sure what could be causing it. any help would be good.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-01-2003, 06:44 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Progressive Hard Starting

ok folks, turns out to be a stuffed spring on the choke. the choke was the only thing i didn't check. prolly should've checked it first, but being late at night in australia i didn't think of it.

so if anyone else has a similar problem, check that the choke is fully closed at start up. I manually closed mine and it fired up first go.

[img]images/graemlins/smile.gif[/img]
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome