Blowing fuse - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-09-2003, 10:59 PM
slugbutt
Guest
 
Posts: n/a
Blowing fuse

Long story short, replaced fuseable link last week with 30 amp fuse etc. Car has ran GREAT until tonight. Noticed on the way home high beam indicator light was on, but my headlights were off. Well I knew to check the fuse for the dome light.

Pulled it and it was blown. Well put in a new one and it blew. Tried another one and it blew. Disconnected the bat. tried another and it blew when I reconnected the batt.

My headlights will work, but no interior lights and no driving lights. Plus the car will crank but will not turn over and run.

Any ideas????

Thanks

Marc [img]images/graemlins/AR15firing.gif[/img] [img]images/graemlins/cussing.gif[/img] [img]images/graemlins/cussing.gif[/img]
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 05-10-2003, 01:07 AM
 
Join Date: Sep 2001
Posts: 2,009
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Blowing fuse

did you reciently hook up a stereo or redo some wiring in the dash you may have hooked up the dash light wire to a ground the dash light wire will test - as long as the lights are turned off but when they are turned on then it will test + had this happen once on a stereo hooked the stereo ground to the dash light + because it tested as a ground
szki272 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome