Joy in Mudville? - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-02-2003, 06:06 PM
slugbutt
Guest
 
Posts: n/a
Joy in Mudville?

I don't want to get ahead of myself, but MY BABY IS UP AND RUNNING.

Crowhorse I followed your directions, to the letter, and IT'S ALIVE.

The reason I am not getting ahead of myself, I still have to reconnect the cd player, but I don't think that will be to bad. I have the diagram and the wires etc. I was just glad when I tried to turn on the cd player it didn't work. If it had I knew I has some SERIOUS problems.

Anyways to make a long story short I put in the 30 amp link and all is well, so far. I am letting it sit overnight and see what happens, but I know it is fixed I am just parinoid by nature. Once something goes wrong you expect everything to go wrong.

Thanks to all who replied to my post and gave some very good insight.

Crowhorse thanks again for all the pics. I have one question what all are you running off of your battery? I have never seen so many wires. LOL Of course I will not be posting any pics of my wiring job because it will PALE in comparision.

Thanks again

Marc [img]images/graemlins/RockOn.gif[/img]

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 05-02-2003, 07:32 PM
Keyboard Implanted
 
CrowHorse's Avatar
 
Join Date: Sep 2000
Location: Sidney, New York
Posts: 3,446
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Joy in Mudville?

Marc, I'm glad it worked out for you!

Connected to the battery:
main fuse, driving lights, starter relay, fuel pump relays, CB, amp, headlight relay, electric fan etc. etc............
CrowHorse is offline  
post #3 of (permalink) Old 05-02-2003, 09:27 PM
slugbutt
Guest
 
Posts: n/a
Re: Joy in Mudville?

One thing I noticed while I was working on the fuse connector. The arm to the alt. is broken maybe someone was watching out for me and keeping it off the road.

For that I am thankful. I am taking back to the shop on Monday and have them replace the arm.

Marc
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome