Torn Mopar Motor Mounts!!! Bugger!!!!!!!! - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-18-2003, 04:42 PM Thread Starter
Keyboard Implanted
 
CrowHorse's Avatar
 
Join Date: Sep 2000
Location: Sidney, New York
Posts: 3,446
Thanks: 0
Thanked 0 Times in 0 Posts
 
Torn Mopar Motor Mounts!!! Bugger!!!!!!!!

Leave it to me to be able to tear motor mounts designed for a v-8. Fact is, I baby my rig and don't dare abuse it as it's my daily driver.....
All was well until I installed the pass. side Mopar mount. I had already installed the driver's side more than a year ago.
I oriented the offset of the mounts to raise the motor. This puts a shear stress on the mount. I can't turn the mounts 180 degrees as my GM alt won't clear the frame.....
Anyone else have a similar misfortune ??......
I'm glad the mounts are cheap.......
CrowHorse is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-18-2003, 05:21 PM Thread Starter
Keyboard Implanted
 
CrowHorse's Avatar
 
Join Date: Sep 2000
Location: Sidney, New York
Posts: 3,446
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Torn Mopar Motor Mounts!!! Bugger!!!!!!!!

Anchor #2469, #2265, #2266





CrowHorse is offline  
post #3 of (permalink) Old 04-18-2003, 05:29 PM
 
Join Date: Aug 2002
Posts: 403
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Torn Mopar Motor Mounts!!! Bugger!!!!!!!!

I stopped at AutoZone and bought mine yesterday for $4 a piece....I got the ones without the interlocking things (just rubber mounts) I am going to use mine to drop the engine....I may have to redrill the holes in the rad mounts and drop it abit to get good clearance for the fan.

I am not running a GM alt so hopefully I wont have any problems putting them in
southpawz is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 04-18-2003, 09:12 PM
Keyboard Implanted
 
Join Date: Nov 2001
Location: North Central Illinois
Posts: 3,928
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Torn Mopar Motor Mounts!!! Bugger!!!!!!!!

Crow,
For some goofy reason , I swear I remember those interlocking mounts to be slightly different in height compared to the standard plain rubber ones . I set mine up lowered , but it actually wanted to be in the other position, up . So far , no probs at all , and they seem indestructible . We all know mine weighs about as much as the Titanic , but how about yours? LOL ....
Sarge
Sarge is offline  
post #5 of (permalink) Old 04-19-2003, 06:31 AM Thread Starter
Keyboard Implanted
 
CrowHorse's Avatar
 
Join Date: Sep 2000
Location: Sidney, New York
Posts: 3,446
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Torn Mopar Motor Mounts!!! Bugger!!!!!!!!

I'm in the light heavy weight division......

Yes, I did notice a small difference in heights, but didn't think that would be any kind of problem.....
CrowHorse is offline  
post #6 of (permalink) Old 04-19-2003, 10:22 AM
 
Join Date: Sep 2001
Posts: 2,009
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Torn Mopar Motor Mounts!!! Bugger!!!!!!!!

i run the ones with inter locks on both sides i also run a gm alternator i did have to trim on the tabs on the drivers side some to clear the oil filter

what i did different is i modified the mount that goes from the frame to the motor mount i welded a tab with a hole in it to the top of it alowing me to run the mount in a position to lower the motor but since it is bolted higher at the frame side the motor sits at a stock heigth
szki272 is offline  
post #7 of (permalink) Old 04-19-2003, 04:13 PM Thread Starter
Keyboard Implanted
 
CrowHorse's Avatar
 
Join Date: Sep 2000
Location: Sidney, New York
Posts: 3,446
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Torn Mopar Motor Mounts!!! Bugger!!!!!!!!

Do you have any pics?
CrowHorse is offline  
post #8 of (permalink) Old 04-19-2003, 04:45 PM
 
Join Date: Sep 2001
Posts: 2,009
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Torn Mopar Motor Mounts!!! Bugger!!!!!!!!

not right at the moment at least not that show the mount good it is realy simple just add some steel to the bracket that bolts to the frame and drill another hole
szki272 is offline  
post #9 of (permalink) Old 05-07-2003, 12:45 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Torn Mopar Motor Mounts!!! Bugger!!!!!!!!

Do you remember the part #'s of the ones you got...or what to ask for years etc....???
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome