Off-Road Forums & Discussion Groups

Off-Road Forums & Discussion Groups (https://forums.off-road.com/forum.php)
-   Suzuki GEO All (https://forums.off-road.com/suzuki-geo-all/)
-   -   Low pressure fuel pump blowing inline fuse (https://forums.off-road.com/suzuki-geo-all/158389-low-pressure-fuel-pump-blowing-inline-fuse.html)

Capn_Crunch 03-20-2003 11:29 AM

Low pressure fuel pump blowing inline fuse
 
I can't seem to trace the problem. I swapped in my spare fuel pump and re-wired it but I'm STILL blowing fuses. Anyone got any ideas? This is on a carbed 1.6-8V... [img]images/graemlins/cussing.gif[/img]

Donald_R 03-20-2003 11:38 AM

Re: Low pressure fuel pump blowing inline fuse
 
Have you tried putting a digital amp meter in line with the pump to measure peak current?
A quality meter will have a memory function.
Most new blade type auto fuses are not designed to handle a peak or spike current load.
Remember the old round fuses? Some of them had a spring inside and were designed for a momentary overload.
Hope this helps.

outlawmws 03-20-2003 01:27 PM

Re: Low pressure fuel pump blowing inline fuse
 
What Donald said, but also, what gage wire did you use? too thin acts as a resistor and heats up,
increasing the load. Catch 22...


All times are GMT -5. The time now is 01:48 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 1994-2009, VerticalScope Inc. // Off Road forums & discussion groups sitemap
side by side | atv | dirtbike | snowmobile | sandsport | competition | land use | Jeep | Toyota | Ford | GM

 
For the best viewing experience please update your browser to Google Chrome