Toy carb - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-16-2003, 07:51 PM Thread Starter
 
Join Date: Dec 2002
Posts: 1,182
Thanks: 0
Thanked 0 Times in 0 Posts
 
Toy carb

and after! [img]images/graemlins/40BEER.gif[/img]
Attached Images
File Type: jpg 1053635-after1.jpg (60.7 KB, 68 views)
AZtoyguy !! is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-16-2003, 08:22 PM
 
Join Date: Aug 2002
Posts: 403
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Toy carb

Hope it works out for ya....

I just finished putting my Weber on mine today....."Holy Sheet" what a diff it makes....I can get it up to 70mph and it is still asking for more [img]images/graemlins/burnout.gif[/img]

I just have to do some small tweaking on it,but got it running pretty good for now.

Let us know how yours runs after ya get it tweaked
southpawz is offline  
post #3 of (permalink) Old 03-16-2003, 08:42 PM
 
Join Date: Apr 2001
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Toy carb

Looking good. Post the results. Sure looks more open,
txgocart is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 03-16-2003, 08:49 PM
Addict
 
Join Date: Apr 2002
Location: Carrollton, Georgia
Posts: 576
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Toy carb

Keep us posted on how it runs. I want to do one on my 88 here. Mine is just a daily driver so to speak.
ka4yqi is offline  
post #5 of (permalink) Old 03-16-2003, 09:26 PM Thread Starter
 
Join Date: Dec 2002
Posts: 1,182
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Toy carb

My 86 is going to be my daily driver now. With the stock carb it would run perfectly then just die like you shut off the gas. Not worth the effort/money to make the stocker right. Just came back from a 15 mile lap around town- it pulls well at low RPMs but has a bit of hesitation when the secondary comes in. Gotta get the idle right, still dies when I clutch at a stopsign and the idle is erratic. Did a rebuild but I bet there's some junk in the idle circuit still, or maybe a vacuum leak. Overall pleased with the result. [img]images/graemlins/40BEER.gif[/img]
AZtoyguy !! is offline  
post #6 of (permalink) Old 03-16-2003, 11:11 PM
 
Join Date: Aug 2002
Posts: 549
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Toy carb

Looks good. Where is that carb from? Does it bolt right on or do you need an adaptor for it?
4x4_Austin_Mini is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome