check engine light not working, any advice - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-25-2003, 10:24 PM Thread Starter
 
Join Date: Feb 2003
Posts: 237
Thanks: 0
Thanked 0 Times in 0 Posts
 
check engine light not working, any advice

89 sidekick 2 door softy i removed the dash to check bulbs it's not the bulb it should light up at start then shut off it don't. it will not come on! it did, now it don't....any suggestions??? all other dash lights working, strange thing is; i have power mirrors & i still can not figure why they are not working either.... the mirrors i can use a test light at the mirror / switch to see if i'm getting power---but the check engine light is a whole'nother ballgame. i don't have a clue where to start to test it?
zukpirate is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome