1.6 TBI on 1.3 Engine - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-31-2002, 05:30 PM Thread Starter
Veteran
 
Join Date: Jul 2002
Location: Wasilla Alaska
Posts: 772
Thanks: 0
Thanked 0 Times in 0 Posts
 
1.6 TBI on 1.3 Engine

Search isn't working.
Who has put a Track/Kick 1.6 TBI Intake manifold onto a Sammy 1.3 TBI Motor?
Can the 1.3 handle the extra fuel?
What all is involved?
Will the 1.3 ECM still work?
How about the EGR system and the water temp sender etc...?
AkDale is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-31-2002, 06:01 PM
Keyboard Implanted
 
zooky's Avatar
 
Join Date: Nov 1999
Location: New Hampshire
Posts: 2,844
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 TBI on 1.3 Engine

I just replied on POR but here you go. Thank god for cut and paste, I type slow...


I did it and am happy with it. It seemed a little rich, then I added a cam and header/ 2" exhaust and it really woke the engine up. I dont remember the details of what I had to do (it was like 2 years ago) but I do remember that it was pretty strait forward. You got to swap a few of the sensors over and reroute a vacuum line or two. It took like an hour to do. Its easy to figure out when you are looking at it. I did notice there are a few different 1.6 TBI's and the earlier ones were easier to adapt. The sami ECM works fine. I knew I should have taken notes!


zooky is offline  
post #3 of (permalink) Old 12-31-2002, 06:14 PM Thread Starter
Veteran
 
Join Date: Jul 2002
Location: Wasilla Alaska
Posts: 772
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 TBI on 1.3 Engine

Are you still running rich?
What are your Cam Specs?
AkDale is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 01-01-2003, 12:21 AM Thread Starter
Veteran
 
Join Date: Jul 2002
Location: Wasilla Alaska
Posts: 772
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 TBI on 1.3 Engine

ttt
AkDale is offline  
post #5 of (permalink) Old 01-01-2003, 01:03 AM
Moderator
 
dparker's Avatar
 
Join Date: Jan 2001
Location: Arkansas.Paragould
Posts: 4,427
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 TBI on 1.3 Engine

if anybody else is intreated i still have everthing off a 1.6 tbi to do this harnes puter intake all email me .
dparker is offline  
post #6 of (permalink) Old 01-01-2003, 01:18 AM
Moderator
 
dparker's Avatar
 
Join Date: Jan 2001
Location: Arkansas.Paragould
Posts: 4,427
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 TBI on 1.3 Engine

heres a pic
Attached Images
File Type: jpg 984971-feb07_02.jpg (93.0 KB, 49 views)
dparker is offline  
post #7 of (permalink) Old 01-01-2003, 07:52 AM
Keyboard Implanted
 
zooky's Avatar
 
Join Date: Nov 1999
Location: New Hampshire
Posts: 2,844
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 TBI on 1.3 Engine

no, not running rich anymore. I was looking for my emmissions paperwork but couldnt find it. There was a big drop in every thing, the engine ran cleaner. The cam is Hawks torquer cam, not sure of the specs
zooky is offline  
post #8 of (permalink) Old 01-01-2003, 07:06 PM Thread Starter
Veteran
 
Join Date: Jul 2002
Location: Wasilla Alaska
Posts: 772
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 TBI on 1.3 Engine

tttt
AkDale is offline  
post #9 of (permalink) Old 01-01-2003, 10:58 PM
Enthusiast
 
Join Date: Jan 2002
Location: Boise Idaho
Posts: 241
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 TBI on 1.3 Engine

Dale,
Here is some info from a past thread. 2 guys talk about their experience.
http://bbs.off-road.com/ubbthreads/s...rue#Post599484
Donald_R is offline  
post #10 of (permalink) Old 01-02-2003, 06:37 AM
Keyboard Implanted
 
Yankee Tim's Avatar
 
Join Date: Mar 2000
Location: Northern Catskill Mountains, NY
Posts: 4,756
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1.6 TBI on 1.3 Engine

Randy,

Didn't you swap the 1.6L head on to it too?
Yankee Tim is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome