solving my rust problem - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-28-2002, 10:34 PM
pook
Guest
 
Posts: n/a
solving my rust problem

got my vacation heading down south.... takening trailer with me... had enough of ne rust.. gonna find a new body tub.. maybe two ,,one just to stick in the top of the garage.. for when the rust demonds get too bad ....wish me luck [img]images/graemlins/burnout.gif[/img]
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-28-2002, 10:38 PM
 
Join Date: Dec 1999
Posts: 1,331
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: solving my rust problem

Where are you heading??
88.5 Samurai is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome