won't shift to 3rd - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-24-2002, 10:01 AM
**DONOTDELETE**
Guest
 
Posts: n/a
won\'t shift to 3rd

I just installed an chevette automatic and it won't seem to bang into 3rd gear. Did i forget to hook something up I reved the snot out of it and it just stays in 2nd and starts to slip. any suggestions?
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-24-2002, 10:09 AM
Keyboard Implanted
 
Join Date: Nov 2001
Location: North Central Illinois
Posts: 3,928
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: won\'t shift to 3rd

Got enough fluid in it ? Also, check the linkage to make sure it's going all the way in . What about the modulator?
Sarge
Sarge is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome