90 Tracker- no heat-i deas - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 10-25-2002, 11:34 PM Thread Starter
Keyboard Implanted
 
Join Date: Jul 2000
Location: NASHVILLE ,IN.
Posts: 2,402
Thanks: 0
Thanked 0 Times in 0 Posts
 
90 Tracker- no heat-i deas

I installed a 190 degree thermostat and the heat gauge rarely ever sees the mid-point of the heat gauge.I had luke warm air when I bought it last year and now I have all cold air.Where is the heat control[90 ,1.6 ,8v.tracker].I put in some 10 minute radiator cleaner about 3 weeks ago and left it in and that did not clean out nothing.I thought about blowing air thru the heater core backwards and hope that opens up something.If that doesnot work,how hard is it to remove the heater core,I hope not as bad as my 88 sami.Thanks for the help,RR
rangerrick is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 10-26-2002, 04:48 PM Thread Starter
Keyboard Implanted
 
Join Date: Jul 2000
Location: NASHVILLE ,IN.
Posts: 2,402
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 90 Tracker- no heat-i deas

btt.its cold, any ideas,thanks RR
rangerrick is offline  
post #3 of (permalink) Old 10-26-2002, 07:34 PM
Keyboard Implanted
 
Join Date: Apr 2000
Location: western MA. USA
Posts: 3,064
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 90 Tracker- no heat-i deas

I would check the control vavle Rick, Just trace it back
near the firwall. If you need a heater core let me know I have a spare I will mail you.
wildweasel is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 10-26-2002, 07:43 PM
 
Join Date: Nov 2001
Posts: 650
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 90 Tracker- no heat-i deas

Trackers have no control valve that shuts off the water flow, just kills the airflow through it. Getting it out isn't supposed to be too difficult but does require pulling most of the dash. (I'm about to find out for the same reasons you mentioned.

Last winter I did take my air tank and sprayer nozzle and blew through the vent up backwards of the normal airflow to remove the junk that blocks airflow.

I'm also considering adding a 2nd heater core in the place where the ac cooling unit would be if I had one.

You're right, its getting cold on my commute to work!
Fastone_84401 is offline  
post #5 of (permalink) Old 10-27-2002, 01:02 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 90 Tracker- no heat-i deas


Might want to make sure there is no blockage in the heater core. Possible might also be an air bubble in the system causing flow problems thru the heater core.
post #6 of (permalink) Old 10-27-2002, 08:02 AM
Keyboard Implanted
 
Join Date: Nov 2001
Location: North Central Illinois
Posts: 3,928
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 90 Tracker- no heat-i deas

Check to make sure the heater hoses are getting hot first . With that done, there should be an air control cable or vacuum control that works the door for heat . Just follow that cable down and verify that the door is moving . Some systems require that one door's movement closes off a second door to make everything work . I'm not real familiar with the Tracker's system , but these are general rules for diagnostics....
Sarge
Sarge is offline  
post #7 of (permalink) Old 10-27-2002, 01:19 PM Thread Starter
Keyboard Implanted
 
Join Date: Jul 2000
Location: NASHVILLE ,IN.
Posts: 2,402
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 90 Tracker- no heat-i deas

Thanks Glenn,if I need one I will get back with you,RR
rangerrick is offline  
post #8 of (permalink) Old 10-27-2002, 01:23 PM Thread Starter
Keyboard Implanted
 
Join Date: Jul 2000
Location: NASHVILLE ,IN.
Posts: 2,402
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 90 Tracker- no heat-i deas

Hi Glenn of RR,I drilled two small holes in my thermostate to fix the air problems,I think the core is plugged.Thanks for the info,RR
rangerrick is offline  
post #9 of (permalink) Old 10-27-2002, 01:24 PM Thread Starter
Keyboard Implanted
 
Join Date: Jul 2000
Location: NASHVILLE ,IN.
Posts: 2,402
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 90 Tracker- no heat-i deas

THANKS Sarge,I will do that.Say hey to the little lady for me,RR
rangerrick is offline  
post #10 of (permalink) Old 10-28-2002, 12:42 AM
 
Join Date: Jun 2001
Posts: 1,628
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 90 Tracker- no heat-i deas

Might want to make sure the blend door is working properly. I had a simialar problem with my 'kick when I got it, and the little loop on the end of the control cable was broken off. A trip to the local Zuki dealer and $6 later, it was fixed.
dschwab9 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome