pics of front missing links needed!!!!! - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 10-24-2002, 01:50 AM Thread Starter
 
Join Date: Jun 2002
Posts: 1,093
Thanks: 0
Thanked 0 Times in 0 Posts
 
pics of front missing links needed!!!!!

i finally received my front missing links today and installed them! i am very happy with the flex i get now but am in bad shape with the shock situation. i have the rears up front with 1"missing links, the rocky road front shock towers and rancho 5012 shocks. the problem is that when the shocks are on, they hit the u bolt plates and dent the shocks. i spaced them out to prevent this but when the tire is stuffed in the wheel well the shock is to long and breaks the welds on the lower shock mount. please give me some pics of your rides that have this set up so i can compare them to mine. any tips or advice would be great! i would like to stay away from a bumpstop if all posssible because i can stuff my tire in the wheel well all the way. thanks in advance!
mykwillisrn is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 10-24-2002, 05:57 AM
Keyboard Implanted
 
Join Date: Nov 2001
Location: Illinois wisconsin border
Posts: 2,729
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: pics of front missing links needed!!!!!

I cut the bump stop off the frame and mounted the shock ontop of the axle like a Toy axle then made new bump stops
It keeps them off of the perch plate.iLL look for a pic later
rockrat is offline  
post #3 of (permalink) Old 10-24-2002, 06:03 AM
 
Join Date: Apr 2001
Posts: 1,454
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: pics of front missing links needed!!!!!

I run the lower mount on top of the axle with a Breeze mount. Upper mounts are ford towers mounted full length up as high as I could get them. With 9012's I have about 4-5" of up travel.
Mini4x is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 10-24-2002, 02:04 PM Thread Starter
 
Join Date: Jun 2002
Posts: 1,093
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: pics of front missing links needed!!!!!

thanks guys! anymore pics would be great!
mykwillisrn is offline  
post #5 of (permalink) Old 10-24-2002, 02:24 PM
Keyboard Implanted
 
Join Date: Nov 2001
Location: Illinois wisconsin border
Posts: 2,729
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: pics of front missing links needed!!!!!

I THOUGHT YOU WERE GOING COILS????
rockrat is offline  
post #6 of (permalink) Old 10-24-2002, 02:39 PM
Keyboard Implanted
 
Zuk Jr.'s Avatar
 
Join Date: Mar 2000
Location: Columbus Ohio
Posts: 2,535
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: pics of front missing links needed!!!!!

<font color="green">I run the TT front and rear YJ missing link. Not sure what you want to see, but here is a pic (attached above)
I run Yota axles and the Frod front shock towers, and shocks (32" ext.) from Advance Auto Parts. </font color>
Attached Images
File Type: jpg 926497-tt1.jpg (24.1 KB, 66 views)
Zuk Jr. is offline  
post #7 of (permalink) Old 10-24-2002, 04:50 PM Thread Starter
 
Join Date: Jun 2002
Posts: 1,093
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: pics of front missing links needed!!!!!

going coils? why do you say that?
mykwillisrn is offline  
post #8 of (permalink) Old 10-24-2002, 05:01 PM
Keyboard Implanted
 
Join Date: Nov 2001
Location: Illinois wisconsin border
Posts: 2,729
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: pics of front missing links needed!!!!!

Guess it was somebody else I sent a [bleep] load of pics to on link setups for coils
rockrat is offline  
post #9 of (permalink) Old 10-25-2002, 01:15 AM Thread Starter
 
Join Date: Jun 2002
Posts: 1,093
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: pics of front missing links needed!!!!!

i'll take some. [img]images/graemlins/grin.gif[/img]
mykwillisrn is offline  
post #10 of (permalink) Old 10-25-2002, 07:12 AM
 
Join Date: Oct 2000
Posts: 932
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: pics of front missing links needed!!!!!

First, you need to clip off the corner of the u-bolt clamp plate on a 45* angle right to the edge of the lockwasher, then round the corners. If you have more than 4" of up travel, then you are going to do more than break the lower shock weld. After you go beyond 4" you are eventually going to kink your springs over the edge of the spring perch. You either have to install a bump stop, or put on a shock with a shorter compressed length as it is now acting as your bump stop and tearing the lower weld off, not to mention the damage it is doing to the shock wiper seal and internals.

HTH, TGT - NCO
NCOffroad is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome