Transfer case problems - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-02-2002, 08:10 PM Thread Starter
Old Hand
 
Join Date: May 2001
Posts: 506
Thanks: 0
Thanked 0 Times in 0 Posts
 
Transfer case problems

One of my friends just bought a 91 zuk for $750. When he tries to shift into anything other than 2wd the shifter gets stuck, we drained the fluid yesterday and it was milky white. Also the tranny has trouble down shifting. Im new to the zooki world so i was just needing some help. Thanks

<a target="_blank" href=http://www.mychevytruck.com/showownerpic.asp?u=3274&amp;n=77633&amp;pos=1&amp; album=6487>http://www.mychevytruck.com/showownerpic.asp?u=3274&amp;n=77633&amp;pos=1&amp; album=6487</a>

97tealZ71 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-02-2002, 09:11 PM
 
Join Date: May 2002
Posts: 2,890
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Transfer case problems

You probably have water in the gear box's. drain and change using cheap stuff, run it a distance to heat it up and drain and change again. Then start looking for how the water got in. Probably the vents, Someone took it swimming. If the gear box's are like that check the diffs too.

as for thre shifting problem it sounds like the shifter sheets (the shifter sheets are shaped dounuts that center the shift lever, nothing sheet like about it.) in both cases. Sami gear box's are notorious for wearing them out, but its an easy cheap fix.
outlawmws is offline  
post #3 of (permalink) Old 09-03-2002, 09:34 AM
 
Join Date: Jun 2001
Posts: 2,731
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Transfer case problems

here is the shifter sheet picture. it is the green dognut at the end.
Attached Images
File Type: jpg 878385-TransferShifter2.jpg (15.4 KB, 1 views)
rich_d is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 09-03-2002, 12:00 PM
SuziCrazy
Guest
 
Posts: n/a
Re: Transfer case problems

I had the same problem when I bought one of mine.. in my case it was that the shifter was removed (don't know why?)and when it was put back, it wasn't lined up with the gears, so I had to manually align the gears (using a long flat screw driver) then placed the shifter back in....
works fine now...

Just another option!
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome