Wragler spring conversion - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-28-2002, 10:04 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Wragler spring conversion

I installed a set of wrangler springs with spoa configuration and missing links in front. I used driveline spacers on front and rear. I took it for a test drive after the install and have a lot of vibration. What could it be?
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-29-2002, 04:09 AM
Keyboard Implanted
 
zooky's Avatar
 
Join Date: Nov 1999
Location: New Hampshire
Posts: 2,844
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Wragler spring conversion

sounds like you put your driveshaft back together out of phase. Make sure the dots on each half of the driveshafts are lined up.
zooky is offline  
post #3 of (permalink) Old 08-29-2002, 08:12 AM
 
Join Date: Sep 2001
Posts: 2,009
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Wragler spring conversion

who's kit or is it a do it your self job i personally used a extended slip yoke in back since the lift is so much and the driveline is so short you are probably about 7 inches over stock
szki272 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome