Clutch ? - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-27-2002, 06:47 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Clutch ?

Newbie to forum...again...was member bout 4 years ago...back from overseas assignment...gotta get er goin again. After cleaning mothballs from 87 Sam...replaced clutch and worked great for about 3 months...now no matter what I constantly have to adjust clutch. I get it just right...and suddenly its over tightened...I make one turn on the cable and its undertightened...driving me nuts.

I feel it may be the bushing on the fork shaft or something else in an alignment area. The shaft may have front to back play or something like that...dunno

Any help from you genious type is greatly appreciated...hunting season right around the corner
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-27-2002, 07:19 PM
Veteran
 
MrSurly's Avatar
 
Join Date: Nov 2001
Location: Central North Carolina
Posts: 1,327
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Clutch ?

My instinct tells me it's probably rust, either in the cable or on the tranny shaft that the throwout bearing rides on. Either rust, or lack of grease. Have you got a spare cable you can put on it? HTH
MrSurly is offline  
post #3 of (permalink) Old 08-28-2002, 06:16 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Clutch ?

theres 2 different adjustments for the clutch.... 1 is more sensative than the other.... (on the cable housing i think) have you tried both of them????
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 08-28-2002, 06:28 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Clutch ?

I also replaced the clutch cable when i replaced the clutch. I've made adjustments to the nut at the end of the cable...and litteraly one turn can be too much adjustment either way. I talked to a tranny repair shop owner yesterday and he asked about the shape the clutch fingers were in when i replaced the clutch. There was some wear and some slight mis-alignment...he suggested replacing this and seeing where that takes me...any thoughts.
post #5 of (permalink) Old 08-28-2002, 08:39 AM
 
Join Date: May 2002
Posts: 2,890
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Clutch ?

Did you use an after market cable or a zuk cable? Its been reported that the (some?) aftermarket housing flexes, and makes it mushy. A follow on to that would be imposible to adjust.

The other possibility is a flexing fire wall or sloppy pedal mechanizum.
outlawmws is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome