Hydraulic clutch master cylinder needed badly! - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-22-2002, 01:53 PM Thread Starter
Can't Get Enough
 
freebird01's Avatar
 
Join Date: Oct 2001
Location: Myerstown, PA
Posts: 1,334
Thanks: 0
Thanked 0 Times in 0 Posts
 
Hydraulic clutch master cylinder needed badly!

ok ive got it narrowed down to the master cylinder....anyone got a good used one out of one of these trackers or sidekicks your parting out for the 16v??

puuulleeaassseee?!?!?!?!
freebird01 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-22-2002, 02:40 PM
Addict
 
James_Holland's Avatar
 
Join Date: Jul 2002
Location: High Wycombe, UK
Posts: 321
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Hydraulic clutch problems with 97 kick sport 1.8

If its not loosing fluid it probably needs bleeding. The 1.8 was not available in the UK. Is it the engine from the Baleno? If so how difficult would it be to swop one into a 1.6 8V?>
James_Holland is offline  
post #3 of (permalink) Old 08-22-2002, 06:46 PM Thread Starter
Can't Get Enough
 
freebird01's Avatar
 
Join Date: Oct 2001
Location: Myerstown, PA
Posts: 1,334
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Hydraulic clutch problems with 97 kick sport 1.8

btt

it was working flawlessly up until today.....my guess is poped a seal in the M/C....

anyone got a good used one they want to sell??
freebird01 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 08-23-2002, 05:45 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Hydraulic clutch problems with 97 kick sport 1.8

you sure its not the slave cyl???
post #5 of (permalink) Old 08-23-2002, 06:54 AM Thread Starter
Can't Get Enough
 
freebird01's Avatar
 
Join Date: Oct 2001
Location: Myerstown, PA
Posts: 1,334
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Hydraulic clutch problems with 97 kick sport 1.8

yep...positive...slave cylinder no leaky [img]images/icons/wink.gif[/img] i even pulled the boot to check to make sure it wasnt going in there....on the inside at the peddle the bottom of the master is a bit wet...not much but a little bit...which tells me it no worky [img]images/icons/smile.gif[/img]
freebird01 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome