power steering problems - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-08-2002, 05:00 PM
**DONOTDELETE**
Guest
 
Posts: n/a
power steering problems

i just finished my power steering install using tracker parts. the problem i am having is that i have to much pressure on the wheel. if feel worse than stock. i used a three inch pulley on the pump, could that be too small. i think i bled the system good. any idea
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-08-2002, 07:32 PM
 
Join Date: Feb 2002
Posts: 467
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: power steering problems

If everything is hooked up right and it doesn't feel like you have power steering I would think it is a bad pump. As for the pulley a 3" pulley is smaller than stock but that would make the pump spin faster which would assist the steering even more. I'm not sure a smaller pulley could cause your pump to wear out faster. You shouldn't have to manually bleed the system, it should bleed it self once you start your engine.
Did you check the fluid after you started your engine?
Tanzuki is offline  
post #3 of (permalink) Old 08-08-2002, 07:33 PM
mikrosilakhan
Guest
 
Posts: n/a
Re: power steering problems

You defiantley missed somewere, mine is one fingerin the wheel lock to lock... Mkae sure its not dragging on the fram or something "pitman arm"
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome