I've been working on things... (part 3) - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-06-2002, 07:51 PM Thread Starter
Veteran
 
MrSurly's Avatar
 
Join Date: Nov 2001
Location: Central North Carolina
Posts: 1,327
Thanks: 0
Thanked 0 Times in 0 Posts
 
I\'ve been working on things... (part 3)

Okay, so I'm the ONLY person who went to Zunami, spent two nights on the beach in a tent with NO FLOOR, got home, went to the store and BOUGHT 200 POUNDS OF SAND for my sandblaster! [img]images/icons/shocked.gif[/img] Robzuk (even surlier than I) welded my SPOA perches on for me, and brought me a pair of stock rear springs. [img]images/icons/smile.gif[/img] 88.5_Samurai brought me some extra leafs for the rear packs and a pair of CJ front springs. [img]images/icons/smile.gif[/img][img]images/icons/smile.gif[/img] I wanted to clean and paint everything, so I fired up the compressor and went to work. The springs were first. I hit all of them with a DA grinder and 36-grit paper to get the rust off. Then I hit them with a wire wheel, and finally the sandblaster. Then the diffs got degreased and blasted. Everything got painted today. (My back hurts!) I even managed to take a few before and after pics:







MrSurly is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-06-2002, 08:26 PM
Carpal \'Tunnel
 
JIMZUKI's Avatar
 
Join Date: May 2001
Location: Liberty Township, OHIO
Posts: 3,350
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: I\'ve been working on things... (part 3)

howdy,
looks good. i sand blasted my leafs before i painted them. i took a part so that i could paint every leaf and installed new plastic things that go between leafs. i was going to do my diffs but them are still looken nice, due to the heavy coat of oil the owner put on them.
JIMZUKI is offline  
post #3 of (permalink) Old 08-06-2002, 09:01 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: I\'ve been working on things... (part 3)

DAMN you did a good job man! Looks REALLY sharp! Oh, and where is my CD? [img]images/icons/wink.gif[/img] hehe I got the engine I am going to rebuild, so I need it! Thanks!
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 08-06-2002, 09:21 PM
 
Join Date: Sep 2001
Posts: 2,018
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: I\'ve been working on things... (part 3)

Yeah those look awesome, congrats and you will be impressed with the flex on those CJ springs. I was until I broke my birfield anyway, which was bout 10 minutes
Samurai202 is offline  
post #5 of (permalink) Old 08-06-2002, 09:28 PM
 
Join Date: Jan 2001
Posts: 499
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: I\'ve been working on things... (part 3)

Nice work!

Jim
Toywagon is offline  
post #6 of (permalink) Old 08-06-2002, 10:33 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: I\'ve been working on things... (part 3)

hey surly, i took apart my spring, well only the bottom one that came off, and painted one separtly, but the reason why i dint paint the others separtly is because i put LIBERAL amounts of grease in between each spring pack, i figgerd it should help ride and flex better, if not, oh well, at least i took the chance.

cant wait dude,

i painted mine a silversh hammered color, from ace hardware (i work there hehe) looks pretty clean and cool, wish i could show pix. you did a very awesome job, * oh yeah, i did all that prep too, but by hand *sand paper, and wire brush heeh, did some with wire wheel*

is that axle glossy black, or chrome lol
post #7 of (permalink) Old 08-06-2002, 11:28 PM
 
Join Date: Jun 2001
Posts: 1,628
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: I\'ve been working on things... (part 3)

You got all that done since Sunday? You need to come visit my house for a couple of days [img]images/icons/smile.gif[/img]

Looks good!

Did you just add the diff armor, or did you already have those caps on there?
dschwab9 is offline  
post #8 of (permalink) Old 08-07-2002, 05:12 AM Thread Starter
Veteran
 
MrSurly's Avatar
 
Join Date: Nov 2001
Location: Central North Carolina
Posts: 1,327
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: I\'ve been working on things... (part 3)

Okay, in response to the questions: The FSM CD will be mailed this week. Sorry for the delay, but I've been working on things! The diff cap was welded on before I painted everything, about five months ago. I did not paint between the leaves of the springs. I figured the friction would rub the paint off anyway. I like to use a spray lubricant called "lock-eze" on my leaf springs because it leaves a graphite residue when it dries. I just respray them whenever they start making noise. The idea of putting grease between the leaves is a good one though. The paint I used was Rustoleum "hard hat" gloss black industrial coating from Home Depot. And yes, I got all that done since Sunday, but I took Tuesday off from work! I just wish I could take the rest of the week off too. I wanna go wheeling!
MrSurly is offline  
post #9 of (permalink) Old 08-07-2002, 05:52 AM
ronin
Guest
 
Posts: n/a
Re: I\'ve been working on things... (part 3)

Looking good, can't wait to see the finished product.
post #10 of (permalink) Old 08-07-2002, 06:20 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: I\'ve been working on things... (part 3)

Yeah, it all looks great...great until you take it offroad for the first time...it will never look the same, but did you build it to drive it or look at it???
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome