just finished installing my 3 core radiator - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-01-2002, 11:10 PM
pugrocker
Guest
 
Posts: n/a
just finished installing my 3 core radiator

Well it is just about 1:00am in New York - just walked upstairs and after a couple of hours of work I finally installed a 3 core radiator and 14" Flex-A-Lite fan with adjustable thermostat........initial impressions are that it definately runs cooler at idle and I don't get the old temp surging that I used to (would run really hot then cool down, run really hot then cool down, etc.).

A couple of test runs down the Long Island Expressway revealed that no matter what temperature I set the fan at it would always run just a hair above the center point on the stock temp guage, but at idle it would remain dead center. I left the thermostat on the electric fan to the lowest setting and it literally stayed on for about 10 minutes after I shut the engine [img]images/icons/crazy.gif[/img]. Time to shower and go to sleep......
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-02-2002, 07:29 AM
 
Join Date: Apr 2001
Posts: 1,454
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: just finished installing my 3 core radiator

Coolio! You fix dat temp gauge??
Mini4x is offline  
post #3 of (permalink) Old 08-02-2002, 08:19 AM
Keyboard Implanted
 
Nowhere's Avatar
 
Join Date: Mar 2001
Location: Altamonte Springs FL
Posts: 3,333
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: just finished installing my 3 core radiator

I did the 3 core w/stock fan. Pedal to the floor in sugar sand she still gets hot but everywhere else all is well.. I am thinking on replacing my stock clutch fan with an electric when I install my suzuki swift gti engine [img]images/icons/laugh.gif[/img].
Nowhere is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 08-02-2002, 08:23 AM
pugrocker
Guest
 
Posts: n/a
Re: just finished installing my 3 core radiator

didn't fix the the temp guage yet - hopefully will bust out the gator grip this weekend and run new lines

post #5 of (permalink) Old 08-02-2002, 08:24 AM
pugrocker
Guest
 
Posts: n/a
Re: just finished installing my 3 core radiator

nowhere - are you still interested in purchasing the Weber and intake? please let me know

thanks
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome