Electrical Problems - Off-Road Forums & Discussion Groups
Suzuki GEO All Discussion of all things, Suzuki and GEO

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-23-2002, 10:02 PM Thread Starter
 
Join Date: Feb 2002
Posts: 196
Thanks: 0
Thanked 0 Times in 0 Posts
 
Electrical Problems

I fixed my engine hesitation problems / bad idle. It was carb icing due to the fact that I took my preheater hose off. Put it back on and it runs like a champ. Started it up today and the fuel gauge pegs out past full.. Great. Drove a few miles and the temp does the same thing. Do you think it's a short? Bad instrament panel? I pulled it out and didn't notice anything obvious. I could live without the temp guage, but I need gas. Any ideas?

Early 88 zuk, 92 Acura Integra seats, soon 2" body lift, 30's
diymobilesound is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-24-2002, 10:08 AM
Keyboard Implanted
 
Join Date: Nov 2001
Location: North Central Illinois
Posts: 3,928
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Electrical Problems

Sounds like your losing your grounds. Check all the grounds in the dash, as well as the engine bay.
Sarge

If it aint broke , I can still fix it...
Sarge is offline  
post #3 of (permalink) Old 02-24-2002, 11:02 AM
 
Join Date: Sep 2000
Posts: 1,509
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Electrical Problems

So a search on this BBS. I believe CrowHorse, or someone else, covered this with good attention to detail & photos awhile back.

Good Luck,

-Farther
Farther is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 02-24-2002, 12:44 PM Thread Starter
 
Join Date: Feb 2002
Posts: 196
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Electrical Problems

Don't the gauges go all the way up when they see ground? IE: maybe one of the wires is grounding out?

Early 88 zuk, 92 Acura Integra seats, soon 2" body lift, 30's
diymobilesound is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome