cdi question - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-28-2001, 05:46 PM
**DONOTDELETE**
Guest
 
Posts: n/a
cdi question

i have a 92 rxl efi with some spark problems . is ti possible for the cdi box to only beable to supply enough energy to spark one coil and not 2 or 3 when i hook them up ? any help would be great .

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-29-2001, 10:21 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: cdi question

My experience has been that if the CDI is working at all it will fire all plugs. Check the ground (brown wire) on the coils. Also the NGK hard plastic plug caps have frequent problems, they vibrate and either wear a groove in the terminal of the plug or they loose their spring tension where they contact the terminal. If you find that to be the problem I would replace them with ones like the current Polaris twins use. Make sure you use a resistor cap because if you don't the non resistor will cause the HALL effect sensor on the EFI to miss fire.

post #3 of (permalink) Old 01-30-2001, 08:01 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: cdi question

I have always been told if the CDI is bad it will not work at all.

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome