93 storm modblaster? - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-22-2001, 01:14 AM
**DONOTDELETE**
Guest
 
Posts: n/a
93 storm modblaster?

I have a 93 storm with psi modblaster pipes. I cant get it to turn the 8600rpm it needs. It calls for 55 gram weights, I put 53grams in and still no luck. it has all the updates done. could my primary spring be worn out. It is polaris blue, the secondary spring is also the blue one. It has a EPI helix 42-34. I have been hitting around 8000-8100rpm not enough to catch the hp. Could my jetting be to fat. My (pto-390) (cntr-400) (mag-390). My gearing is 23-37. PSI recommends 23-35. Has any body had any luck with them pipes, please email me [email protected]
thank you.

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome