SkiDoo Troubles - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-11-2000, 03:12 PM
**DONOTDELETE**
Guest
 
Posts: n/a
SkiDoo Troubles

I have a 1993 Mach I 670 Rotax - not sure if my problem is fuel or electrical? Acts like its starved for fuel or ignition system is not getting spark all the time. Anybody have any suggestions we have 10 inches of snow and I'm in the house on-line!! Help!!

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-12-2000, 02:24 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: SkiDoo Troubles

Make sure that you have the correct spark plug and that it is in good/new condition. If you have non-resistor plugs and it calls for resistor, it can foul up the Ign. pick up coil/module and lose spark. What does the piston wash look like? How about the spark plugs?

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome