1997 ZR580 EFI messed up! HELP! - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-15-2005, 06:43 PM
the1foryou
Guest
 
Posts: n/a
1997 ZR580 EFI messed up! HELP!

I have recently purchased this 97 zr580 efi, and it started (ran but could not run more than 1000rpm without pumping the throttle) when picked up at 5 degrees outside. Now i have brought it home to my garage where its about 60 to 65 it will not start... is it the ECU or what would be more likely?
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-22-2005, 08:54 PM
 
Join Date: May 2004
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1997 ZR580 EFI messed up! HELP!

Came across a similar problem with the same type sled. Was told it was the ECU. But talked to a couple of other guys and they said it's not the ECU. They told me to try the coolant temp. sensor under the thermostat housing. Cost about $70.00. Just ordered one today. I'll let you know if it takes care of the problem. Another thing to check for is water in the fuel. Just a thought. The $70.00 part is a lot cheaper than $400.00 (used) to $2,000.00 (New) ECU. Let me know if you come across something different. Also, do you happen to have a wiring diagram of this sled. I could use one. If so send it to my e-mail address: [email protected] Thanks.
FoundOnResDead is offline  
post #3 of (permalink) Old 01-04-2006, 08:26 PM
the1foryou
Guest
 
Posts: n/a
Re: 1997 ZR580 EFI messed up! HELP!

I've tested ohm resistance in the injectors and tps sensor, along with all the other sensors related to fuel. They have all checked out within the correct deviations. I'll try the coolant temp sensor next. Thanks and if i run across anything I'll post it!
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 01-06-2006, 08:04 AM
 
Join Date: May 2004
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 1997 ZR580 EFI messed up! HELP!

I'll bechanging the sensor on the sled this weekend if everything works out I'll let you know.
FoundOnResDead is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome