73 Elan 16 HP burning out plugs - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-03-2005, 05:30 PM
rasorbackq
Guest
 
Posts: n/a
73 Elan 16 HP burning out plugs

What causes a sled to go through spark plugs. Been running the sled now for a month and 2 new plugs are good for about 3 days . Plugs are not fouled still look almost new . Put in 2 more and continue for 3-4 days start all over . I am running NGKs 7BS Started with 8BS NGKs . Any ideas??????
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-17-2006, 01:51 AM
Old Hand
 
mach2_nh's Avatar
 
Join Date: Oct 2002
Location: Milford NH USA
Posts: 1,045
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 73 Elan 16 HP burning out plugs

Hmm.. no clue. but i run NGK 8BS on my 399 all is good here.
I have had them die on me. i keep some with me now.
mach2_nh is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome