93 Pantera 580 engine/fuel problem? - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-14-2004, 02:40 PM
slednut
Guest
 
Posts: n/a
93 Pantera 580 engine/fuel problem?

The engine starts very hard after sitting over night I seem to think it is not getting fuel, the fuel pump sounds like it is working very hard and its loud. Once I get it going it runs very well at low speeds (0-50 miles/hour). If i try to driver faster than 55 miles an hour one cylinder will start to miss and finaly shut down, (the left cyl only). If I stop and let it idle for less than a min the cyl will catch again and the engine runs very well again (under 50 miles/hour). This is driving me crazy can anyone point me in the right direction to correct this fault. Engine compression is 140 PSI in both cylinders. I fix cars for a living however I don't know much about sleds.

Thank You
Dave Penney
Canada
Email ([email protected])
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-16-2004, 09:51 AM
 
Join Date: Nov 2004
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 93 Pantera 580 engine/fuel problem?

Sounds like the carb for the left sides needs adjustment and/or cleaning or rebuilding. Sounds like either the carb or fuel distribution is starving the left side. Have you changed the plugs?
Scarto is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome