1978 Yamaha EX340B - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 11-23-2003, 04:09 PM
*Shaggy*
Guest
 
Posts: n/a
1978 Yamaha EX340B

Hi i'm kind of stumped, my sled idles but as soon as i try opening the throttle, it bogs down and will die after a few seconds, i've cleaned the carb good, put in a new float valve, checked the float height, it was good, put new engine gaskets on, tried new spark plugs, i can't figure it out. I've played with the idle mixture screw.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-06-2005, 07:17 AM
*Shaggy*
Guest
 
Posts: n/a
Re: 1978 Yamaha EX340B

I forgot to reply to this, anyway turns out a little mouse was helping me out by living in my exhaust pipe, soon as I cut the pipe apart and removed the nest, it worked good.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome