81 Blizzard Sucking Air - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-18-2000, 02:43 PM
**DONOTDELETE**
Guest
 
Posts: n/a
81 Blizzard Sucking Air

Thanks for all your help! I believe i finally found the problem although not the cure. It appears i'm sucking air in the fuel lines. I've replaced the fuel lines and eliminated the primer lines and that did'nt take care of it. Is it possible, or should i say probable that the fuel pump itself could be causing this? Thanks again!

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-18-2000, 11:51 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 81 Blizzard Sucking Air

Great to hear you are making progress! You can buy a rebuild kit for the pump from half a dozen diff. aftermarket suppliers for about $12.00 .You might also check 2 other things,on a sled of that vintage you may want to go ahead and replace the plastic fuel lines from tank to carbs just for cheap insurance and also fish the fuel line clunk out of the tank and either clean or replace it,again its only about $4.00 aftermarket and for my money you may as well replace it all and be done with it! Good luck!

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome