El Tigre -Need Help - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-06-2000, 09:21 AM
**DONOTDELETE**
Guest
 
Posts: n/a
El Tigre -Need Help

Having problems with my '79 Arctic Cat El Tigre. It starts without any problems. Then, when I start to throttle it, the engine boggs down and doesn't have any power. It doesn't stall, just no power. Plugs are fine, replaced fuel and added de-icer. Any suggestions? Please help. Thanks!

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-06-2000, 09:30 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: El Tigre -Need Help

Years ago I had a '81 El Tigre that had a similar problem. After checking the plugs, gas, etc., I took the carbs off and cleaned them. Ta Da! Try it and see if it cures the problem.

post #3 of (permalink) Old 02-19-2000, 12:11 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: El Tigre -Need Help

Control,
Try removing your rubbers from the carbs to the breather box and see if that makes a difference and if that does, your breather box has to be pulled out and taken apart and cleaned. There is a metal grater in there that plugs up. Would like to know if I'm right. Thanks.

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome