Formula Z Carb problems - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-17-2000, 05:27 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Formula Z Carb problems

I have a 1995 Formula Z 583, it has a low end bog (below 2500rpms). What would cause something like this? I just got the sled about 2 weeks ago. It has around 2800 miles on it(now!) and is in very nice shape. I was told it could be something in the R.A.V.E. valves, is this possible?

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-19-2000, 01:41 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Formula Z Carb problems

low end bog is a good sign of dirty or pluggged air jets on your carbs, if you havent done so yet it would be a good idea to pull them off and have a look. if this sled is new to you, you dont know how the last guy treated it!! hope this helps.

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome