Off-Road Forums & Discussion Groups

Off-Road Forums & Discussion Groups (https://forums.off-road.com/forum.php)
-   Snowmobile Lounge (https://forums.off-road.com/snowmobile-lounge/)
-   -   Kawasaki carb problems (https://forums.off-road.com/snowmobile-lounge/17596-kawasaki-carb-problems.html)

**DONOTDELETE** 01-06-2000 02:36 AM

Kawasaki carb problems
 
Ive got a Kawasaki 440 LTD. It has dual butterfly carbs. The left carb(when facing the intake side of the engine) is not metering fuel. I have taken it apart several times, cleaned it, blown out every hole, and still get the same problem. I know the bowl is full of fuel, and I know the engine is fine, because if I spray gas into the throat of the carb, It fires perfectly.
I just rebuilt the engine 2 years ago, so I want to fix the thing.

Anyone got a carb they want to sell?

I have some slide mikuni's off of a 340 blizzard and the cables. Could I adapt these and jet them up?


snownut 01-06-2000 09:47 AM

Re: Kawasaki carb problems
 
I would check your fuel pump first, before replacing carbs. Maybe switch sides and see if you get the same response.

Snownut


**DONOTDELETE** 01-08-2000 10:14 PM

Re: Kawasaki carb problems
 
Sounds like it could be a bad crank seal. It"s not allowing any crank pressure to take the fule in.


**DONOTDELETE** 01-09-2000 05:59 PM

Re: Kawasaki carb problems
 
I didnt even think of that! Ill check that. You are probably right.
Kurt



All times are GMT -5. The time now is 05:58 PM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright 1994-2009, VerticalScope Inc. // Off Road forums & discussion groups sitemap
side by side | atv | dirtbike | snowmobile | sandsport | competition | land use | Jeep | Toyota | Ford | GM

 
For the best viewing experience please update your browser to Google Chrome