1996 Polaris Xlt 600 triple need help! - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-04-2000, 03:24 PM
**DONOTDELETE**
Guest
 
Posts: n/a
1996 Polaris Xlt 600 triple need help!

My 1996 Polaris Xlt 600 triple was running great until on a 30 degree day I started it up and sounded really boggy. Sounds fine at mid to high speed. I changed the plugs and still sounds bogged down. Any ideas?

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-05-2000, 10:50 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 1996 Polaris Xlt 600 triple need help!

Engines run richer when the air is warmer. You might want to check your needle clip settings. Moving the clip up lowers the needle in the needle jet and leans out the mixture at lower throttle.

post #3 of (permalink) Old 01-05-2000, 11:59 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 1996 Polaris Xlt 600 triple need help!

Jetting, my old 97xlt with the 38mill carbs was really temp sensitive. Vinman

Sponsored Links
Advertisement
 
post #4 of (permalink) Old 01-06-2000, 07:36 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: 1996 Polaris Xlt 600 triple need help!

Unfortunately I wasn't savvy enough to jet my own XLT. I should have learned. Fortunately I passed the dealership everytime I went riding....It took about 3 rides to get it where I was happy with it. It would run fine until about 7000ft. Then I couldn't even get up the trail any further

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome