Off-Road Forums & Discussion Groups

Off-Road Forums & Discussion Groups (https://forums.off-road.com/forum.php)
-   Snowmobile Lounge (https://forums.off-road.com/snowmobile-lounge/)
-   -   1996 Polaris Xlt 600 triple need help! (https://forums.off-road.com/snowmobile-lounge/17591-1996-polaris-xlt-600-triple-need-help.html)

**DONOTDELETE** 01-04-2000 03:24 PM

1996 Polaris Xlt 600 triple need help!
 
My 1996 Polaris Xlt 600 triple was running great until on a 30 degree day I started it up and sounded really boggy. Sounds fine at mid to high speed. I changed the plugs and still sounds bogged down. Any ideas?


**DONOTDELETE** 01-05-2000 10:50 PM

Re: 1996 Polaris Xlt 600 triple need help!
 
Engines run richer when the air is warmer. You might want to check your needle clip settings. Moving the clip up lowers the needle in the needle jet and leans out the mixture at lower throttle.


**DONOTDELETE** 01-05-2000 11:59 PM

Re: 1996 Polaris Xlt 600 triple need help!
 
Jetting, my old 97xlt with the 38mill carbs was really temp sensitive. Vinman


**DONOTDELETE** 01-06-2000 07:36 PM

Re: 1996 Polaris Xlt 600 triple need help!
 
Unfortunately I wasn't savvy enough to jet my own XLT. I should have learned. Fortunately I passed the dealership everytime I went riding....It took about 3 rides to get it where I was happy with it. It would run fine until about 7000ft. Then I couldn't even get up the trail any further



All times are GMT -5. The time now is 01:23 AM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright 1994-2009, VerticalScope Inc. // Off Road forums & discussion groups sitemap
side by side | atv | dirtbike | snowmobile | sandsport | competition | land use | Jeep | Toyota | Ford | GM

 
For the best viewing experience please update your browser to Google Chrome