73 Alpine Skidoo problem - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-20-2003, 06:43 PM
**DONOTDELETE**
Guest
 
Posts: n/a
73 Alpine Skidoo problem

Purchased used 73 Alpine Skidoo, double track, single ski. Starts and will run with throttle wide open (kinda fun since 700+cc), floods and stalls if you slow down, worse when warm. Have put in new plugs, new carb kit, and second hand coils but problem still there. What next?

Also steers poorly, especially left.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-20-2003, 09:41 PM
 
Join Date: Aug 2002
Posts: 549
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 73 Alpine Skidoo problem

What kind of carb is on it. It is most likely a carb problem.

If it's a tilletson then check the return line if it's plugged. Maybe the low speed screw is too far out, to check this just count how many turns in you can go before it bottoms out and if it's more then 2 then only turn it it out 1.5 turns and start it and adjust it from there. Also if it has the style needle where the arm attaches to the needle make sure the arm is adjusted right or the needle will stay wide open.
[img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img] [img]images/graemlins/40BEER.gif[/img]
If it's a mikuni then check the asjustment of you needle or put a smaller idle jet in.
[img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img] [img]images/graemlins/burnout.gif[/img]
Could you fill out your profile please, like city, country, name etc. Just go to your "My Home" and click on "Edit" where it says "Personal information, email, password, etc." Thank You.
4x4_Austin_Mini is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome