I need help - Off-Road Forums & Discussion Groups
Snowmobile Lounge All general discussions relating to Snowmobiles

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-10-2003, 04:39 PM
lakota
Guest
 
Posts: n/a
I need help

I have a 1980 Ski Doo Blizzard twin MIC carbs 340 7500
My problem is the sled has a good idle low end 0-25 mph is ok but, when you go to full thottle the sled spudders and after about 5 seconds it will take off. If you have a open strech when it takes off it will run about 90mph great!!

Things I have tried
New plugs
the right plug looks good but the left plugs is wet
the carbs are clean
the jet adjust on the right carb is 11/2 turns out
the jet adjust was 2 turns out
I have turned the left carb jet adjust in to about 1/4 turn out and the sled has a little less hesatation but the plug is stll wet both plugs have good spark. I thing that I have noticed is that the left plug when I remove it will release exhust but the right one will not ( this right when I shut it off then remove plugs. Can anyone help Thanks Mark
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-10-2003, 10:40 PM
oultman
Guest
 
Posts: n/a
Re: I need help

It may not be in the engine at all, sounds like it could be in the clutching. Clutching has a bigger effect on the engines performance than people think. They have been known to cause sputters in the mid range. Try looking there for a problem.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome