HPI Racing Firestorm 10T - Stadium Truck Review - Off-Road Forums & Discussion Groups
RC-Nitro For discussion of off-road, gas (Nitro) powered, radio controlled model vehicles.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-11-2007, 10:53 PM Thread Starter
Mud in my Veins
 
DezertScorpion's Avatar
 
Join Date: Mar 2005
Location: San Diego, CA
Posts: 6,228
Thanks: 0
Thanked 4 Times in 4 Posts
 
HPI Racing Firestorm 10T - Stadium Truck Review



Hi All,

I just wanted to let you guys know about this kick-ass HPI Racing Nitro stadium truck. The HPI Racing Firestorm 10T rocks!

Read Review

Please let us know what you think about HPI Racing's off-road line of R/C's.

Thanks,

-DZ

DezertScorpion
DezertScorpion is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-28-2007, 12:47 PM
ismail
Guest
 
Posts: n/a
Smile help

i have bought a firestorm 10t and it is pretty impressive until it stops working. i have tried so many times trying to start it up but it just won't work. have tried priming it to get the fuel; to the carburator and i have tried to start it up but it will not start. does anyone have any ideas why it won't start

many thanks

ismail
post #3 of (permalink) Old 08-29-2007, 01:15 AM Thread Starter
Mud in my Veins
 
DezertScorpion's Avatar
 
Join Date: Mar 2005
Location: San Diego, CA
Posts: 6,228
Thanks: 0
Thanked 4 Times in 4 Posts
 
HPI Racing Customer Support

Quote:
Originally Posted by ismail View Post
i have bought a firestorm 10t and it is pretty impressive until it stops working. i have tried so many times trying to start it up but it just won't work. have tried priming it to get the fuel; to the carburator and i have tried to start it up but it will not start. does anyone have any ideas why it won't start

many thanks

ismail
Hi Ismael,

I have had this happen to me also. Try switching out the Glow Plug with a new one. Make sure you are using new Nitro fuel, not stuff that has been sitting around.

I'm no expert, but these things have worked for me. If that doesn't work, call HPI Customer Support at 1-888-349-4474. I have called them before and they are very helpful.

Good luck!

-DZ

DezertScorpion
DezertScorpion is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome