FL250 Get up and Go IS Gone - Off-Road Forums & Discussion Groups
Pilot & Odyssey All messages on Honda Pilot's Odyssey's and other Small Sand Cars.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-07-2009, 07:16 PM Thread Starter
 
Join Date: Jul 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Thumbs down FL250 Get up and Go IS Gone

I have a 1982 fl250 odyssey that the engine throttles up great on, but the speed of kart is alot lower than the engine rpm's. It acts like the belt or clutch is slipping but both the drive and driven pulley's are moving in and out fine, and the belt was replaced about a year ago and looks to have no wear. The chain inside the gear differential box was replaced about 2 years ago and doesn't make any sounds to be loose. Engine starts and runs great just has no speed out of the gate. Can somebody PLEASE help me with this, big family reunion this weekend (7/11/09) and all the kids are gonna want to ride our Odyssey!!!!!
tinytanic1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome