2001 Arctic Cat 300 engine problems - Off-Road Forums & Discussion Groups
Performance ATV Mods Discussion of ATV Performance Modifications.

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 10-02-2003, 07:44 AM
**DONOTDELETE**
Guest
 
Posts: n/a
2001 Arctic Cat 300 engine problems

Has any one had any problems with the attached subject? My 300 quit on me - no bang - no hesitation - just shut down. It has 1,051 miles on it! The machine has beed extreamly well maintained, 4 oil and filter chnages in less than 1000 miles?!
Took it to the dealer, who tore it down and discovered a "broken valve stem" among other things. If anyone has had this problem can you let me know. </font><blockquote><font class="small">In reply to:</font><hr />


[/ QUOTE ]
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome