Turn Signal Issues, Need Help Quick - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-22-2001, 03:07 PM Thread Starter
 
Join Date: Aug 2000
Posts: 4,282
Thanks: 0
Thanked 0 Times in 0 Posts
 
Turn Signal Issues, Need Help Quick

Ok so I'm a genius and spray the inside of my TJ out w/ a hose, including the dash. Now my turn signal buzzer thinggy makes a real quick tick all the time execpt when you actually turn on a turn signal or hazzards, the lights arn't flashing when it's making the tick and the turn signals work when you turn them on. What should I do? any way to disable the buzzer, I was cleaning my jeep for homecomming tonight and I have about 4 hours till I have to pick up my date, help quick.

Thanks,

BarrelRoll

97 TJ

Wheel it or drive a minny van

Jeeper99xj is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-22-2001, 03:33 PM Thread Starter
 
Join Date: Aug 2000
Posts: 4,282
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Turn Signal Issues, Need Help Quick

ok, it's stoped for now, any ideas if it comes back?

BarrelRoll

97 TJ

Wheel it or drive a minny van

Jeeper99xj is offline  
post #3 of (permalink) Old 09-22-2001, 03:46 PM Thread Starter
 
Join Date: Aug 2000
Posts: 4,282
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Turn Signal Issues, Need Help Quick

Ok, it's back now, it goes off when i hit the break though, I don't have a clue what's up, I'm going to check out the wiring, please help

97 TJ

Wheel it or drive a minny van

Jeeper99xj is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 09-22-2001, 04:08 PM
Old Hand
 
Join Date: Nov 2000
Location: Selah Wa
Posts: 524
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Turn Signal Issues, Need Help Quick

dont hose it out any more. Got any WD40 spray that in your connections. Thats what its original intent was for Water Displacement it took 40 tries to get the formula right. Thus WD40

I make Half doors, for pics click here http://communities.msn.com/Grimjeepe...halfdoors.msnw
mike34 is offline  
post #5 of (permalink) Old 09-22-2001, 06:16 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Turn Signal Issues, Need Help Quick

Just a thought, try hitting the fuse block with compressed air. Pull your flasher(s) thingy (big round things on the dfuse block), dry them off and hit the areas with air. I flooded my rig out once and basically it was the same thing, after drying out the fuse block, it was all back to normal.

BentMetal

83CJ7 still limping along but getting better daily.
post #6 of (permalink) Old 09-22-2001, 06:58 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Turn Signal Issues, Need Help Quick

don't buy into the hose out thing, unless your only hosing out the tub. Don't go near the dash. sounds like you have a short somewhere, wd-40 would work, like mentioned. or air. or just live with it, might stop after water dries out

'01TJeff

"Roads? Where we're going; we don't need...roads"
post #7 of (permalink) Old 09-23-2001, 07:09 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Turn Signal Issues, Need Help Quick

All of the above ( air, WD40) are the things I would do too.
On the driver side under the dash (under the front left speaker) you'll fid those flasher thingies... make sure there is no water in them or in any of the fuses... I don't see what else could be wrong...
That must have been one hell of a hosing !

Desertbuzz
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome