can't get my cj7 running - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-21-2000, 11:02 PM
**DONOTDELETE**
Guest
 
Posts: n/a
can\'t get my cj7 running

I hope this msg isn't too boring for this newsgroup, but I need some advice please. My 1984 CJ-7 258 was sitting for about 3 months over the winter and now it doesn't want to start.

So far I know the starter works, the carb is getting fuel (I even tried starter fluid...), and there is spark (I held a screwdriver up to a spark plug wire and saw an arc). After these first few checks, I replaced the spark plugs, distributor cap, rotor and ohmed out the spark plug wires - all were between 4k-7kohms. When I try to start it, the engine just won't fire up, not even any backfires. However, stepping on the gas does rev up the engine while its trying to start.

Can someone help me figure out what to check next?
Thanks a bunch in advance!
Erik

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-22-2000, 10:38 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: can\'t get my cj7 running

Sounds to me like a case of the ignition timing deciding to go WAY off, did the distributor come loose?

Brad
ORC Land Use Section Editor
Get involved or lose it all, the choice is yours!
post #3 of (permalink) Old 03-22-2000, 11:11 AM
 
Join Date: Feb 2000
Posts: 1,181
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: can\'t get my cj7 running

timing or compression problems, start with a compression check.

[img]/wwwthreads_images/icons/cool.gif[/img] Big Ed
<font color=red>'88 YJ, 4" susp,3" body,33's,283 Chevy V8,TH350,4.11's,D30,D35c</font color=red>
v8jeep is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 03-22-2000, 05:22 PM
 
Join Date: Sep 1999
Posts: 1,066
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: can\'t get my cj7 running

try running some fresh gas to the carb ,It may have gone stale .or you may have water or condensation in the gas tank.or lines...Hope you have oil in it.(did you winterize it after parking it ? )although nothing is impossible....I don't think your timing would go out of wack just sitting.Although your lifters may have leaked .

Learn to let go of what does not serve you ,but forces you to serve it
unhumen is offline  
post #5 of (permalink) Old 03-22-2000, 06:34 PM
Official Curmudgeon
 
CJ7Taz's Avatar
 
Join Date: Nov 2001
Location: Kansas
Posts: 4,705
Thanks: 2
Thanked 5 Times in 5 Posts
 
Re: can\'t get my cj7 running

I agree, drain the tank, the lines and the carb then get some fresh gas.


CJ7Taz is offline  
post #6 of (permalink) Old 03-22-2000, 10:38 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: can\'t get my cj7 running


thanks for the inputs guys.

Just now, I tried pouring some fresh gas in the carb and that didn't work. Also, the distributor wasn't loose, so I'm pretty sure the timing didn't get all out of whack.

Is it possible that the ignition switch on the steering column has a bad contact or something, so that when the key is in "ON" position it doesn't make contact?

it seems like I'm running out of things to check...

thanks again in advance

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome