94 JGC. got spark, won't start. help please - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-09-2001, 08:34 AM Thread Starter
 
Join Date: Dec 2000
Posts: 785
Thanks: 0
Thanked 0 Times in 0 Posts
 
94 JGC. got spark, won\'t start. help please

here is the situation: 1994 jgc 4.0L. tuesday night, my neighbor (his truck) started it and moved it around in the drive. wed morning, went to start and it would turn over, but not fire. wed night i pulled a spark plug and there is spark, and the plugs are wet. when i push the little valve in the tes-fitting in the fuel rail, it barely shoots out, maybe 3in. or so. i think i can hear the fuel pump run. my neighbor has been renting it to his brother for the last 4 months and his brother ran it out of gas twice. i am going to put new plugs in it tonigh (it needs them!)and try to do some other diagnostic work. anything i should look for? tried checking the codes and all i get is a 55. is the fuel pressure supposed to be 37-41 psi on these 4.0L also? thanks for any info! matt


jeepnmatt is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-09-2001, 08:35 AM Thread Starter
 
Join Date: Dec 2000
Posts: 785
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: 94 JGC. got spark, won\'t start. help please

NEW DEVELOPMENTS! this morning, just for fun, i thought i'd try and start it. it cranked over, idled kinda rough, then smoothed out. i let it run for 2-3 minutes to help charge up the battery and turned it off. immediately tried to restart it and it sputtered once or twice and then would only turn over, not fire. any possiblilty this could be the Crank Position Sensor? or do you still think its the fuel pump? i am going to work on it tonight. thanks for any info! matt


jeepnmatt is offline  
post #3 of (permalink) Old 03-09-2001, 08:39 AM
Way Outta Control
 
Join Date: Sep 1999
Location: The Palouse
Posts: 13,432
Thanks: 1
Thanked 3 Times in 3 Posts
 
Re: 94 JGC. got spark, won\'t start. help please

Here's my idea.. and I'm shootin' in the wind on this one... The SMPI guys will know more than I do on this one...

Check the CPS senser. You may be getting spark, but:

1. Is it at the right time?
2. A fuel injector should pulse at, or around the same time.
3. Do you hear the an injector fire?

If no injectors are firing, you've got to find out why...


LEVE
LEVE is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome