TFI Coil supposed to make noise? - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-22-2001, 11:26 PM
**DONOTDELETE**
Guest
 
Posts: n/a
TFI Coil supposed to make noise?

I Just performed the TR ignition upgrade. all went well, except for one problem. well, its not really a problem. I mounted the Filko TFI coil to my firewall (which is fiberglass) and when the engine is running, the coil makes a funny, annoying rattle noise that can be heard very well in the cab. It sounds just like when there is a leaf in the way of the heater blower motor (i know it is not this, b/c the heat is off). i was just curious, is this normal? I have headers with glass packs and you can hear the noise over the exhaust with the hood open. i cant imagine a stock, quiet ford taurus with a coil rattling away like this. maybe it is just the fiberglass resonating the sound. what do you all think?

Thanks!
Justin
'83 CJ-7, 258 I6

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-23-2001, 07:48 AM
Can't Get Enough
 
Join Date: Mar 2000
Location: So. Jersey
Posts: 1,003
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: TFI Coil supposed to make noise?

All 4 corners mounted flat? Vibrating? Have someone put hand(with glove) on coil to dampen while engine is running. Maybe make up or buy some soft rubber isolation washers for coil/bracket and bracket/firewall. Run a ground wire for any radio interference. ???.

JimmyZ is offline  
post #3 of (permalink) Old 01-23-2001, 08:47 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: TFI Coil supposed to make noise?

JimmyZ...
Yes, the coil is mounted solidly to the firewall. i skimped on the bracket though, i mounted the coil directly to the firewall via the 4 mounting holes. there is no radio interference i have noticed yet, b/c i havent turned on the radio yet. it actually is vibrating, i felt it like you suggested with a glove.

Thanks.

Justin
www.geocities.com/jeepboyjus
'83 CJ-7, 258, TR ignition, headers, T5/D300, 3" suspension, 1" body, Moser 1 pce axles, Model 20, 3.54:1
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 01-23-2001, 08:49 PM
Enthusiast
 
Join Date: Sep 1999
Location: Des Moines, IA
Posts: 370
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: TFI Coil supposed to make noise?

I'm not an expert, but doesn't the coil need to be grounded? It's usually grounded through the mount. One of the TFI brackets I found in the junk yard was mounted to a plastic inner fender and it had a ground wire attached to the bracket. It also seems like having a good ground at the coil has been mentioned before. Maybe you did ground yours, but it didn't sound like it from the post.

jerry

jerry is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome