No EGR valve on a 94 4.0? Emissions? - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-19-2001, 09:25 AM Thread Starter
I Might Just Know What I'm Talking About
 
Pete88YJ's Avatar
 
Join Date: Sep 1999
Location: BOSTON
Posts: 1,748
Thanks: 0
Thanked 0 Times in 0 Posts
 
No EGR valve on a 94 4.0? Emissions?

Hi all,
Trying to get some help for my buddy with a 94 4.0 YJ. He failed emissions here in MA on the dyno - high NOx. (I did too, but my EGR valve was bad, and I replaced it.) I'm being told that he found out there's no EGR valve on a 94 4.0. Is this true? Anybody know how to lower NOx on a 94 4.0? I understand it is high combustion temp. related, and EGR lowers this.

Thanks all for any help
Pete [img]/wwwthreads_images/icons/cool.gif[/img]

88 YJ-retiring to trails soon
79 4WD F250-hauler/tower of my toys [img]/wwwthreads_images/icons/smile.gif[/img]
70 Jaguar E-type - the best car England ever made. [img]/wwwthreads_images/icons/cool.gif[/img]
??? pavement-pounder for work/school - opinions wanted.
Pete88YJ is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-20-2001, 06:32 AM
sas87yj
Guest
 
Posts: n/a
Re: No EGR valve on a 94 4.0? Emissions?

yeah my chiltons says 91 and newer have no egr valve![img]/wwwthreads_images/icons/smile.gif[/img]

post #3 of (permalink) Old 01-20-2001, 11:21 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: No EGR valve on a 94 4.0? Emissions?

Have you checked to see if the cat was plugged. I think I heard this caused a high Nox reading before someplace...

Tommy B. in AZ -
More Guts than Brains.
[img]/wwwthreads_images/icons/tongue.gif[/img] WHASSSUP!?!?!?!?
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 01-20-2001, 09:18 PM
Mac
 
Join Date: Sep 1999
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: No EGR valve on a 94 4.0? Emissions?

Running lean, or Coolant temp too high will cause NOx. Check them first. Make sure it is not running too hot. The running lean makes the combustion temp go up.

Hope that helps!



[img]/wwwthreads_images/icons/cool.gif[/img] Mac [img]/wwwthreads_images/icons/cool.gif[/img]

75 CJ5 Almost Never will be done
Mac is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome