Need help with 4L80-E Trans. - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-07-2000, 11:58 PM Thread Starter
Old Hand
 
Join Date: Sep 1999
Location: Corona CA
Posts: 742
Thanks: 0
Thanked 0 Times in 0 Posts
 
Need help with 4L80-E Trans.

I have a 95 2500 Sub 4X4 with the 454 and the 4L80-E trans, it has 71,000 and I have owned it since 59,000. The Sub is used on the
weekends as the family car and about once a month is used for towing a CJ5.

About 2 months ago while towing the CJ5 I started smelling trans fluid so on the following Monday I had the Chevy dealer do the power
flush to change the fluid. Now while driving it seems like its slipping, going into OD it seems like it doesn't fully make the up shift. If I let off
the gas and then floor it it will complete the shift. The fluid smell is gone though.

Do any of you have any info? The CJ is an 83 and I know the Jeep inside out, the Sub is a different story and I don't want to get screwed
taking it to a shop without some knowledge from you guys.

WildCJ5

WildCJ5 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-10-2000, 02:40 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Need help with 4L80-E Trans.

It sounds like you may have overheated it, the trans may have a bad seal or clutch pack. The sprags seem to be a weak point, also. The Hummers seem to go thru these trannys quite regularly at our dealership, the newer ones have many improvements. Whatever is wrong with it, add the largest cooler you can find.

Good luck!

post #3 of (permalink) Old 09-11-2000, 07:45 AM
 
Join Date: Feb 2000
Posts: 1,181
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Need help with 4L80-E Trans.

I have a 4L60 (which is a lighter weight version of your 4L80) in my '96 K1500. I burnt it up several months ago while trying to go up a hill in overdrive. Symptoms at first were similar to yours, OD slipping then it would shift back to 3rd and try to find OD again. Finally it locked into 4th and the tack went to 4K so I let off and had to drive home in 2nd. When EITHER 3rd or 4th go, BOTH gears are gone, something with how it's built inside. I got quotes to rebuild it for $1K with a 6mo warranty. Ended up getting a deal from the dealer, $1300 and a 50K warranty, transferable to the next owner (I will NOT own the truck when 50K is up!)
Just keep an eye on yours and don't go into OD unless you are over 50mph, that'll increase the life of it.

[img]/wwwthreads_images/icons/cool.gif[/img] Big Ed
<font color=red>'88 YJ, 4" susp,3" body,35's,283 Chevy V8,TH350,4.11's,D30,D35c</font color=red>
v8jeep is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome