Squeal Noise from my hub?? - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-23-1999, 11:46 PM
**DONOTDELETE**
Guest
 
Posts: n/a
Squeal Noise from my hub??

I have just recently noticed a noise coming from my passeger side front hub of my 85 cj7. The sound is a squeal that gets quicker with each revoultion of the tire. It only happens when I'm in 4wd. When I'm not in 4wd and I've left the hubs locked it is more of a thud and when the they aren't locked there is no sound at all. I just put superwinch hubs on this summer, so I know this shouldn't be the cause of the problem. If anyone could help me out w/ the problem it would be appreciated! thanks

Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-24-1999, 12:11 AM
Addict
 
jeepnut_nh's Avatar
 
Join Date: Mar 2002
Location: near Nashua, NH
Posts: 484
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: Squeal Noise from my hub??

I'd say look at the u-joint on the front axle shaft, and if that's the culprit, replace both sides cause the other won't be far behind this one

good luck


<font color=white> jimbo</font color=white>

<font color=green>'74 CJ5,232 I6,T15,Dana 30&44</font color=green>
jeepnut_nh is offline  
post #3 of (permalink) Old 12-24-1999, 07:05 AM
**DONOTDELETE**
Guest
 
Posts: n/a
Re: Squeal Noise from my hub??

I've checked the ujoints already and they look fine... any other suggestions?

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome