304 Idle - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-09-1999, 08:43 PM
**DONOTDELETE**
Guest
 
Posts: n/a
304 Idle

I have a 79 Cj7 with a 304. I installed a Holley 600 carb and Edelbrock
intake. It has no smog equipment. The engine runs very smooth. The
problem is it won't idle below 1000 rpms with the idle screw all
the way out and slack in the throttle cable. I am hesitante to put
smaller main jets in for fear of running too lean. It has two vacuumn
lines, PCV valve and advance. Any help appreciated.


Jim
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-09-1999, 11:02 PM
cjjunkie
Guest
 
Posts: n/a
Re: 304 Idle

Check to make sure that the throttle blades are not hanging up somewhere on a gasket,or manifold both internally and externally.
are you using a good double return spring?
check for a vaccumn leak.
Are you running ported or manifold vaccumn ?
check the ignition timing.


Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome