Off-Road Forums & Discussion Groups

Off-Road Forums & Discussion Groups (https://forums.off-road.com/forum.php)
-   Jeep-Short Wheelbase (https://forums.off-road.com/jeep-short-wheelbase/)
-   -   engine lacks power wtf (https://forums.off-road.com/jeep-short-wheelbase/232486-engine-lacks-power-wtf.html)

GhostBS 06-13-2009 11:23 AM

engine lacks power wtf
 
I have a 1976 cj5 renegade with a rebuilt 304v8. i replaced just about everything else under the hood when i bought it. it was running fine untill recently it started to lose power when i accelerate. it feels like i trying to pull something thats weighs way more than my jeep can pull. it also sounds like air is escaping... the tranny is also having some issues. when i shift into secon gear it pops back out... i am sorry if these questions have already been asked, i searched and couldnt find any answers...

JeepDawg 06-13-2009 12:09 PM

It's probably having to carry too much WTF. Get rid of some of the WTF and the jeep will be lighter.

The air escaping sound is a clue that you most likely have a big vacuum leak.

There are a couple of ways to find it...
1. Listen for the source of the sound
2. Start pinching vac hoses until it goes away
3. Use the propane gas trick

Have you noticed a loss of braking power? If so, it could be the brake booster.

Jim_Lou 06-13-2009 01:31 PM

It could also be a plugged muffler or exhaust pipe, or a frozen heat riser valve.

The heat riser valve is between the exhaust manifold and the exhaust pipe on one side. If it sticks in the closed position, it forces almost all of the exhaust from that head to squeeze through a little passage under the intake to the other side of the engine. With the engine cold you should be able to rotate it freely. If it's stuck, work on it with penetrant and patience until it's completely free.

GhostBS 06-13-2009 01:43 PM

now it won't even start... the exhaust is custom, its basically headers and straight pipe... i am not getting any fuel to the carb, i just replaced the fuel pump and filter and its still not getting any... and no my gas tank is not empty...

GhostBS 06-13-2009 02:19 PM

got her to start, she still bogs down... i don't really think there is an air leak now, some hoses were loose and i put them back on all the way. for the heat riser valve do i have to take off my headers?

Jim_Lou 06-13-2009 04:00 PM

You may not have one. Look for a spacer about a half inch thick with a 5/16" shaft through it between the collector and the down pipe. Grab the shaft with pliers and see if it turns. If there's no spacer or the shaft turns the problem is something else. In that case, look for the link to RRich's Propane Trick in the welcome post.

Caver Dave 06-14-2009 09:15 AM

Quote:

Originally Posted by GhostBS (Post 1546215)
I have a 1976 cj5 renegade with a rebuilt 304v8. i replaced just about everything else under the hood when i bought it. it was running fine untill recently it started to lose power when i accelerate. it feels like i trying to pull something thats weighs way more than my jeep can pull. it also sounds like air is escaping...


Quote:

Originally Posted by GhostBS (Post 1546221)
now it won't even start... the exhaust is custom, its basically headers and straight pipe... i am not getting any fuel to the carb, i just replaced the fuel pump and filter and its still not getting any... and no my gas tank is not empty...

How can you hear anything going on with the engine with straight pipes blaring? My glasspacks were enough to mask 75% of engine issues!

Sounds like fuel *may* still be the issue. IOW, if you replaced the pump & filter and aren't getting fuel, there could be a pinhole on the fuel supply line somewhere between the pump and the pickup or pickup sock is filthy. Pull the supply line at the pump and use a hose into a gas can (safe distance from any sparks!)... should confirm/deny this theory.

Guessing the "air leak" you hear could be just the carbs venturi noise or a disconnected smog pump?

Quote:

Originally Posted by GhostBS (Post 1546222)
got her to start, she still bogs down... i don't really think there is an air leak now, some hoses were loose and i put them back on all the way. for the heat riser valve do i have to take off my headers?

What did you do to get it to start? Spun it over until the FP primed? Starting fluid until it hit? It could take a while for fuel to make it to the engine once prime is lost!

IMO, skip looking for the heat riser valve, if you do have headers, I've never seen a set plumbed with the valve...

At this point, *if* you're getting fuel to the carb & it's stock (no Holley/4v crap), I'll wager it needs to be torn down & thoroughly CLEANED! This is based many years with a very cold natured MC2100 that would run great today and wouldn't get out of it's own way tomorrow. Luckily, the 2100 is one of the simplest carbs on the planet to mess with. I put mine on the shelf this year in favor of "DIY" TBI... and won't look back! :D

GhostBS 06-14-2009 09:47 AM

i think its a vacuum leak, i checked the fuel issues and it didn't fix it. i couldn't get it to start because i was an idiot.... my garage is at a steep angle, once i leveled out the jeep with a jack it started fine... i can't here hissing but what i can hear is the loss of power, its a really deep undertone almost like its trying to suck something up. I know it's not the carb, its a brand new edelbrock! i plan on just taking it to my mechanic and having him find the problem and then i'll fix it. i don't want to go through the hassle of building the propane test kit... thanks for all the help guys

myscrambler1 06-14-2009 11:17 AM

loss of power
 
hi just wanted to tell you i had a problem just like yours on my 81 jeep cj8 scrambler with sb chevy motor and eb 600 preformer carb..... really had several problems that casued motor to run bad and too rich...... would allways start but sometimes seemed ok for short time or if you shut off and restarted then would miss and run rough.........anyway it turned out to be vac leaks around the intake and base of the carb........... I would first make sure all intake bolts are tight...... you can use reg carb clearner,,,,,, just be carefull and have fire ex handly if you would start a motor fire......if your careful you should be ok...... the motor will speed up if you have a vac leak and when you spray the intake you will see big change in the motor speed........do same thing on and around the base of the carb......if that still does not make a difference...... take out both of the idle adj for both sides of the eb carb and blow them out with comspressed air....... these carbs are great but just a little crap in the fuel line will cause big problems ........when i got the vac leaks fixed and changed out the fuel filter then with the air bleu out the carb a couple of times all the problems went away and it is running great again......hope this helps...........one more thing...... eb ships all their carbs out on the rich side with the size of step rods springs and jets in their carbs.......... they are set up more for hot rods then a good smooth running motor......... if you rejet down a couple of sizes the carb with run better burn less fuel and you wont even feel any loss in power///// in fact you will have a quicker response and better runing motor except maybe on the very top end ....... and that would be way over 5,000 rpm which is not what we use our motors for or at in the jeeps anyway........

Caver Dave 06-15-2009 07:27 AM

Quote:

Originally Posted by GhostBS (Post 1546254)
I know it's not the carb, its a brand new edelbrock!

Why do you ASSuME the carb isn't at fault? Carbs are like underwear, 1 size does NOT fit all! Also, there's a huge difference between "new" and "tuned".... knowing the exact engine/requirements it's going on is NOT info the carb builder can gain w/o ESP/crystal ball/Carnak!


All times are GMT -5. The time now is 06:38 AM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright 1994-2009, VerticalScope Inc. // Off Road forums & discussion groups sitemap
side by side | atv | dirtbike | snowmobile | sandsport | competition | land use | Jeep | Toyota | Ford | GM

 
For the best viewing experience please update your browser to Google Chrome