O/T 97 ZJ won't stay running until at op temp - Off-Road Forums & Discussion Groups
Jeep-Short Wheelbase All discussion of short wheelbase Jeeps: CJ, TJ, YJ and JK

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-02-2005, 07:29 PM Thread Starter
Veteran
 
babypoo's Avatar
 
Join Date: May 2003
Location: Milwaukee(which is algonquin for the good land)WI U.S.A
Posts: 755
Thanks: 0
Thanked 0 Times in 0 Posts
 
O/T 97 ZJ won\'t stay running until at op temp

wifes 97 ZJ 4.0L won't stay running unless you keep your foot on the gas until it warms up any suggestions?
John
babypoo is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-02-2005, 08:40 PM
Way Outta Control
 
Join Date: Sep 1999
Location: usa
Posts: 10,815
Thanks: 0
Thanked 1 Time in 1 Post
 
Re: O/T 97 ZJ won\'t stay running until at op temp

Check for vacuum leaks.
RRich is offline  
post #3 of (permalink) Old 12-02-2005, 09:50 PM
 
Join Date: Feb 2003
Posts: 556
Thanks: 0
Thanked 0 Times in 0 Posts
 
Re: O/T 97 ZJ won\'t stay running until at op temp

Some items to check: Remove and clean TB with TB cleaner, removed electrical controls before cleaning>> It sounds like you may have a bad temp sensor, if this is bad the computer thinks the engine is hot and leans out the fuel mixture when it should send a rich mixture....TPS may be bad. as previous post noted look for bad vacuum connections.
tincan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Off-Road Forums & Discussion Groups forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome